Get in touch
Back
Maintenance

Update for beta build of SFX page

Completed 4 Jul at 07:08pm BST.

bot.expiredminotaur.com
Completed

Bot is running normally

Posted 4 Jul at 07:08pm BST.
Updated

Bot is running again, awaiting monitors to return to normal

Posted 4 Jul at 07:02pm BST.
Started

A Beta version is being uploaded to the server for testing

Posted 4 Jul at 06:54pm BST.