Get in touch
Back
Downtime

Some services are down

Started 28 Oct at 04:56pm BST, resolved 28 Oct at 09:24pm BST.

bot.expiredminotaur.com
Resolved

Moved to new server

Posted 28 Oct at 09:24pm BST.
Created

Bot is down due to server price increase

Posted 28 Oct at 04:56pm BST.